1.2 release - problems with RAT plugin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

1.2 release - problems with RAT plugin

Les Hazlewood-2
I'm trying to run:

> mvn rat:check

But when I do this, maven executes what apparently is an older
org.codehaus.mojo rat-maven-plugin

I had to explicitly execute:

> mvn org.apache.rat:apache-rat-plugin:0.8:check

and then it executed as expected.

Is something wrong with our POM or am I doing something incorrectly?
The apache rat plugin should execute for us always.  What's up? Any
pointers would be appreciated.

Thanks!

Les
Reply | Threaded
Open this post in threaded view
|

Re: 1.2 release - problems with RAT plugin

kaosko
It's so easy to trip on this (I've done it myself!) but the answer is
in what you wrote: the name of the plugin is apache-rat, not rat, so
"mvn apache-rat:check" is the correct command. It fails though and we
are running an older version. I can take care of it right now unless
specifically want to work on it.

Kalle


On Wed, Jan 18, 2012 at 2:57 PM, Les Hazlewood <[hidden email]> wrote:

> I'm trying to run:
>
>> mvn rat:check
>
> But when I do this, maven executes what apparently is an older
> org.codehaus.mojo rat-maven-plugin
>
> I had to explicitly execute:
>
>> mvn org.apache.rat:apache-rat-plugin:0.8:check
>
> and then it executed as expected.
>
> Is something wrong with our POM or am I doing something incorrectly?
> The apache rat plugin should execute for us always.  What's up? Any
> pointers would be appreciated.
>
> Thanks!
>
> Les
Reply | Threaded
Open this post in threaded view
|

Re: 1.2 release - problems with RAT plugin

Les Hazlewood
Administrator
Nah, it's ok - I've upgraded to the latest 0.8 and I've fixed all
compatibility errors - committing the last now...

On Wed, Jan 18, 2012 at 3:45 PM, Kalle Korhonen
<[hidden email]> wrote:

> It's so easy to trip on this (I've done it myself!) but the answer is
> in what you wrote: the name of the plugin is apache-rat, not rat, so
> "mvn apache-rat:check" is the correct command. It fails though and we
> are running an older version. I can take care of it right now unless
> specifically want to work on it.
>
> Kalle
>
>
> On Wed, Jan 18, 2012 at 2:57 PM, Les Hazlewood <[hidden email]> wrote:
>> I'm trying to run:
>>
>>> mvn rat:check
>>
>> But when I do this, maven executes what apparently is an older
>> org.codehaus.mojo rat-maven-plugin
>>
>> I had to explicitly execute:
>>
>>> mvn org.apache.rat:apache-rat-plugin:0.8:check
>>
>> and then it executed as expected.
>>
>> Is something wrong with our POM or am I doing something incorrectly?
>> The apache rat plugin should execute for us always.  What's up? Any
>> pointers would be appreciated.
>>
>> Thanks!
>>
>> Les
Reply | Threaded
Open this post in threaded view
|

Re: 1.2 release - problems with RAT plugin

kaosko
Oops - think I got there first.

Kalle


On Wed, Jan 18, 2012 at 4:03 PM, Les Hazlewood <[hidden email]> wrote:

> Nah, it's ok - I've upgraded to the latest 0.8 and I've fixed all
> compatibility errors - committing the last now...
>
> On Wed, Jan 18, 2012 at 3:45 PM, Kalle Korhonen
> <[hidden email]> wrote:
>> It's so easy to trip on this (I've done it myself!) but the answer is
>> in what you wrote: the name of the plugin is apache-rat, not rat, so
>> "mvn apache-rat:check" is the correct command. It fails though and we
>> are running an older version. I can take care of it right now unless
>> specifically want to work on it.
>>
>> Kalle
>>
>>
>> On Wed, Jan 18, 2012 at 2:57 PM, Les Hazlewood <[hidden email]> wrote:
>>> I'm trying to run:
>>>
>>>> mvn rat:check
>>>
>>> But when I do this, maven executes what apparently is an older
>>> org.codehaus.mojo rat-maven-plugin
>>>
>>> I had to explicitly execute:
>>>
>>>> mvn org.apache.rat:apache-rat-plugin:0.8:check
>>>
>>> and then it executed as expected.
>>>
>>> Is something wrong with our POM or am I doing something incorrectly?
>>> The apache rat plugin should execute for us always.  What's up? Any
>>> pointers would be appreciated.
>>>
>>> Thanks!
>>>
>>> Les
Reply | Threaded
Open this post in threaded view
|

Re: 1.2 release - problems with RAT plugin

Les Hazlewood-2
No worries - it didn't break anything for me.  Thanks for the help!

On Wed, Jan 18, 2012 at 4:05 PM, Kalle Korhonen
<[hidden email]> wrote:

> Oops - think I got there first.
>
> Kalle
>
>
> On Wed, Jan 18, 2012 at 4:03 PM, Les Hazlewood <[hidden email]> wrote:
>> Nah, it's ok - I've upgraded to the latest 0.8 and I've fixed all
>> compatibility errors - committing the last now...
>>
>> On Wed, Jan 18, 2012 at 3:45 PM, Kalle Korhonen
>> <[hidden email]> wrote:
>>> It's so easy to trip on this (I've done it myself!) but the answer is
>>> in what you wrote: the name of the plugin is apache-rat, not rat, so
>>> "mvn apache-rat:check" is the correct command. It fails though and we
>>> are running an older version. I can take care of it right now unless
>>> specifically want to work on it.
>>>
>>> Kalle
>>>
>>>
>>> On Wed, Jan 18, 2012 at 2:57 PM, Les Hazlewood <[hidden email]> wrote:
>>>> I'm trying to run:
>>>>
>>>>> mvn rat:check
>>>>
>>>> But when I do this, maven executes what apparently is an older
>>>> org.codehaus.mojo rat-maven-plugin
>>>>
>>>> I had to explicitly execute:
>>>>
>>>>> mvn org.apache.rat:apache-rat-plugin:0.8:check
>>>>
>>>> and then it executed as expected.
>>>>
>>>> Is something wrong with our POM or am I doing something incorrectly?
>>>> The apache rat plugin should execute for us always.  What's up? Any
>>>> pointers would be appreciated.
>>>>
>>>> Thanks!
>>>>
>>>> Les