I want to rename this to SpringIniWebConfiguration prior to 0.9 final to
avoid any potential conflict or confustion that might arise - it is a hybrid
of .ini and Spring config really - spring config of the SecurityManager,
realms, etc, and .ini configuratino for filter and url config.
The reason I make this distinction is because an (accurately named)
SpringWebConfiguration can be wholly-contained in a Spring xml file, with no
.ini constructs at all. The WebConfiguration interface itself mandates only
two methods: getSecurityManager and
There is nothing about these two methods that imply .ini at all, so that
means a JSecurity spring-configured web app could put 100% of its config in
a Spring file and ignore web.xml entirely if they so desired. If that was
the case, and we implemented a class to support this, that class _should_ be
But the existing SpringWebConfiguration uses .ini constructs, which aren't
necessary in the above scenario, hence my desire for the name change.